Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04amZtLXJnbWctM3dxMs4AATm6

Apache Archiva vulnerable to Cross-site Scripting

Cross-site scripting (XSS) vulnerability in Apache Archiva prior to version 2.2.1 allows remote authenticated administrators to inject arbitrary web script or HTML via the connector.sourceRepoId parameter to admin/addProxyConnector_commit.action.

Permalink: https://github.com/advisories/GHSA-8jfm-rgmg-3wq2
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04amZtLXJnbWctM3dxMs4AATm6
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 4.8
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-8jfm-rgmg-3wq2, CVE-2016-5005
References: Blast Radius: 1.0

Affected Packages

maven:org.apache.archiva:archiva
Dependent packages: 0
Dependent repositories: 0
Downloads:
Affected Version Ranges: < 2.2.1
Fixed in: 2.2.1
All affected versions: 2.2.0
All unaffected versions: 2.2.1, 2.2.3, 2.2.4