Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS04bXZ3LTIycjctdzZmcc3iEg

ruby_parser allows local users to overwrite arbitrary files via symlink attack on temporary file with predictable name

The diff_pp function in lib/gauntlet_rubyparser.rb in the ruby_parser gem 3.1.1 and earlier for Ruby allows local users to overwrite arbitrary files via a symlink attack on a temporary file with a predictable name in /tmp.

Permalink: https://github.com/advisories/GHSA-8mvw-22r7-w6fq
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS04bXZ3LTIycjctdzZmcc3iEg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: almost 2 years ago
Updated: 8 months ago


Identifiers: GHSA-8mvw-22r7-w6fq, CVE-2013-0162
References: Repository: https://github.com/seattlerb/ruby_parser
Blast Radius: 0.0

Affected Packages

rubygems:ruby_parser
Dependent packages: 186
Dependent repositories: 33,689
Downloads: 108,997,833 total
Affected Version Ranges: >= 2.0.2, < 3.1.2
Fixed in: 3.1.2
All affected versions: 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.1.0, 3.1.1
All unaffected versions: 1.0.0, 2.0.0, 2.0.1, 3.1.2, 3.1.3, 3.2.0, 3.2.1, 3.2.2, 3.3.0, 3.4.0, 3.4.1, 3.5.0, 3.6.0, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.8.0, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9.0, 3.10.0, 3.10.1, 3.11.0, 3.12.0, 3.13.0, 3.13.1, 3.14.0, 3.14.1, 3.14.2, 3.15.0, 3.15.1, 3.16.0, 3.17.0, 3.18.0, 3.18.1, 3.19.0, 3.19.1, 3.19.2, 3.20.0, 3.20.1, 3.20.2, 3.20.3, 3.21.0