Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Advisories: GSA_kwCzR0hTQS04cjZoLW03MnYtMzhmZ84AAxBj

Shopware vulnerable to Improper Input Validation of Clearance sale in cart

Impact

It is possible to put the same line item multiple one in the cart using API, the Cart Validators checked the line item's individuality and the user was able to skip the clearance sale in cart

Patches

The problem has been fixed with 6.4.18.1

Workarounds

For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. Or disable the newsletter registration completely.

References

https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates

Permalink: https://github.com/advisories/GHSA-8r6h-m72v-38fg

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 11 days ago
Updated: 4 days ago

CVSS Score: 6.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Identifiers: GHSA-8r6h-m72v-38fg, CVE-2023-22730
References:

Affected Packages

packagist:shopware/core
Versions: <= 6.4.18.0
Fixed in: 6.4.18.1
packagist:shopware/platform
Versions: <= 6.4.18.0
Fixed in: 6.4.18.1