An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05MzdmLXFoM3ctNmc4N84AAu--

OctoPrint vulnerable to Insufficient Session Expiration.

If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists. This issue is fixed in version 1.8.3.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 year ago
Updated: 10 months ago

CVSS Score: 4.4
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Identifiers: GHSA-937f-qh3w-6g87, CVE-2022-2888

Affected Packages

Versions: < 1.8.3
Fixed in: 1.8.3