Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05N3c5LWdjYzctdnI4Z84AAv5O

Insufficient Entropy in PHPServerMon PRNG

A vulnerability, which was classified as problematic, was found in phpservermon. This affects the function generatePasswordResetToken of the file src/psm/Service/User.php. The manipulation leads to use of predictable algorithm in random number generator. The exploit has been disclosed to the public and may be used. The name of the patch is 3daa804d5f56c55b3ae13bfac368bb84ec632193. It is recommended to apply a patch to fix this issue. The identifier VDB-213717 was assigned to this vulnerability.

Permalink: https://github.com/advisories/GHSA-97w9-gcc7-vr8g
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05N3c5LWdjYzctdnI4Z84AAv5O
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: 10 months ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-97w9-gcc7-vr8g, CVE-2021-4240
References: Repository: https://github.com/phpservermon/phpservermon
Blast Radius: 1.0

Affected Packages

packagist:phpservermon/phpservermon
Dependent packages: 0
Dependent repositories: 0
Downloads: 80 total
Affected Version Ranges: < 3.6.0
Fixed in: 3.6.0
All affected versions: 3.1.0, 3.1.1, 3.2.0, 3.2.1, 3.2.2, 3.3.0, 3.3.1, 3.3.2, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.5.0, 3.5.1, 3.5.2
All unaffected versions: