Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05NTIzLTQ3NHgtNWgzNs4AAi-2

Cross site scripting in Jenkins Mission Control Plugin

Jenkins Mission Control Plugin 0.9.16 and earlier does not escape job display names and build names shown on its view, resulting in a stored XSS vulnerability exploitable by attackers able to change these properties.

Permalink: https://github.com/advisories/GHSA-9523-474x-5h36
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05NTIzLTQ3NHgtNWgzNs4AAi-2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-9523-474x-5h36, CVE-2019-16563
References: Blast Radius: 1.0

Affected Packages

maven:tech.andrey.jenkins:mission-control-view
Affected Version Ranges: <= 0.9.16
No known fixed version