Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05ZjM3LWdneG0taDZ3eM4AAmvW

CSRF vulnerability in Jenkins Shelve Project Plugin

Jenkins Shelve Project Plugin 3.0 and earlier does not require POST requests for HTTP endpoints, resulting in cross-site request forgery (CSRF) vulnerabilities.

These vulnerabilities allow attackers to shelve, unshelve, or delete a project.

Jenkins Shelve Project Plugin 3.1 requires POST requests for the affected HTTP endpoints.

Permalink: https://github.com/advisories/GHSA-9f37-ggxm-h6wx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05ZjM3LWdneG0taDZ3eM4AAmvW
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: 4 months ago


CVSS Score: 8.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H

Identifiers: GHSA-9f37-ggxm-h6wx, CVE-2020-2321
References: Repository: https://github.com/jenkinsci/shelve-project-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:shelve-project-plugin
Affected Version Ranges: <= 3.0
Fixed in: 3.1