Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05ajJwLThxcWYtaDU1Y84AAxl7

Cross-site Scripting in UDX Stateless Media Plugin

A vulnerability was found in UDX Stateless Media Plugin 3.1.1. It has been declared as problematic. This vulnerability affects the function setup_wizard_interface of the file lib/classes/class-settings.php. The manipulation of the argument settings leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.2.0 is able to address this issue. The name of the patch is 6aee7ae0b0beeb2232ce6e1c82aa7e2041ae151a. It is recommended to upgrade the affected component. VDB-220750 is the identifier assigned to this vulnerability.

Permalink: https://github.com/advisories/GHSA-9j2p-8qqf-h55c
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05ajJwLThxcWYtaDU1Y84AAxl7
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: 9 months ago


CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-9j2p-8qqf-h55c, CVE-2022-4905
References: Repository: https://github.com/udx/wp-stateless
Blast Radius: 1.0

Affected Packages

packagist:wpcloud/wp-stateless
Dependent packages: 0
Dependent repositories: 0
Downloads: 34 total
Affected Version Ranges: < 3.2.0
Fixed in: 3.2.0
All affected versions: 1.6.0, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.8.0, 1.9.0, 1.9.2, 2.0.1, 2.0.2, 2.0.3, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.2.7, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.1.0, 3.1.1
All unaffected versions: 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.3.0, 3.4.0, 3.4.1, 4.0.0, 4.0.1, 4.0.2, 4.0.3