Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05ajY1LTNmMnEtOHEycs4AAxpk

Cross-site Scripting in Jenkins Pipeline: Build Step Plugin

Jenkins Pipeline: Build Step Plugin 2.18 and earlier does not escape job names in a JavaScript expression used in the Pipeline Snippet Generator, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control job names.

Permalink: https://github.com/advisories/GHSA-9j65-3f2q-8q2r
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05ajY1LTNmMnEtOHEycs4AAxpk
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 year ago
Updated: 3 months ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-9j65-3f2q-8q2r, CVE-2023-25762
References: Repository: https://github.com/jenkinsci/pipeline-build-step-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:pipeline-build-step
Affected Version Ranges: <= 2.18
Fixed in: 2.18.1