Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05cDhqLWhyZ2YtamMyZ84AAwdQ

Apache Zeppelin Cross-site Scripting vulnerability

An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Zeppelin allows logged-in users to execute arbitrary javascript in other users' browsers. This issue affects Apache Zeppelin before 0.8.2. Users are recommended to upgrade to a supported version of Zeppelin.

Permalink: https://github.com/advisories/GHSA-9p8j-hrgf-jc2g
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05cDhqLWhyZ2YtamMyZ84AAwdQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-9p8j-hrgf-jc2g, CVE-2022-46870
References: Blast Radius: 0.0

Affected Packages

maven:org.apache.zeppelin:zeppelin
Dependent packages: 0
Dependent repositories: 1
Downloads:
Affected Version Ranges: < 0.8.2
Fixed in: 0.8.2
All affected versions: 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1
All unaffected versions: 0.8.2, 0.9.0, 0.10.0, 0.10.1, 0.11.0, 0.11.1