Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05cjNoLXdtM3gtdjI0Nc4AAlOm

RCE vulnerability in ElasticBox Jenkins Kubernetes CI/CD Plugin

ElasticBox Jenkins Kubernetes CI/CD Plugin 1.3 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types. This results in a remote code execution (RCE) vulnerability exploitable by users able to provide YAML input files to ElasticBox Jenkins Kubernetes CI/CD Plugin’s build step.

Permalink: https://github.com/advisories/GHSA-9r3h-wm3x-v245
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05cjNoLXdtM3gtdjI0Nc4AAlOm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-9r3h-wm3x-v245, CVE-2020-2211
References: Blast Radius: 1.0

Affected Packages

maven:com.elasticbox.jenkins-ci.plugins:kubernetes-ci
Affected Version Ranges: <= 1.3
No known fixed version