An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05cmZyLXBmMngtZzR4Zs4AA6JJ

GeoServer's Style Publisher vulnerable to Stored Cross-Site Scripting (XSS)


A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources or in a specially crafted datastore file that will execute in the context of another user's browser when viewed in the Style Publisher. Access to the Style Publisher is available to all users although data security may limit users' ability to trigger the XSS.


Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer.


Complete instructions, including specific configuration details, to reproduce the vulnerability.


If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can:

1 .Perform any action within the application that the user can perform.
2. View any information that the user is able to view.
3. Modify any information that the user is able to modify.
4. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user.


Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 month ago
Updated: about 1 month ago

CVSS Score: 4.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-9rfr-pf2x-g4xf, CVE-2024-23640
References: Repository:
Blast Radius: 1.0

Affected Packages

Affected Version Ranges: < 2.23.3
Fixed in: 2.23.3
Affected Version Ranges: < 2.23.3
Fixed in: 2.23.3