Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05cmo5LTV3Y3YteGdmMs3JYg

Roundup Improper Access Control

The EditCSVAction function in cgi/actions.py in Roundup 1.2 before 1.2.1, 1.4 through 1.4.6, and possibly other versions does not properly check permissions, which allows remote authenticated users with edit or create privileges for a class to modify arbitrary items within that class, as demonstrated by editing all queries, modifying settings, and adding roles to users.

Permalink: https://github.com/advisories/GHSA-9rj9-5wcv-xgf2
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05cmo5LTV3Y3YteGdmMs3JYg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: about 1 month ago


Identifiers: GHSA-9rj9-5wcv-xgf2, CVE-2009-2737
References: Repository: https://github.com/roundup-tracker/roundup
Blast Radius: 0.0

Affected Packages

pypi:Roundup
Dependent packages: 0
Dependent repositories: 3
Downloads: 226 last month
Affected Version Ranges: >= 1.4, <= 1.4.6, >= 1.2, < 1.2.1
Fixed in: 1.4.7, 1.2.1
All affected versions: 1.2.0, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.6
All unaffected versions: 0.5.9, 0.6.8, 0.6.9, 0.6.11, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.7, 0.7.8, 0.7.9, 0.7.11, 0.7.12, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 1.0.1, 1.1.0, 1.1.1, 1.1.2, 1.2.1, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.4.7, 1.4.8, 1.4.9, 1.4.10, 1.4.11, 1.4.12, 1.4.13, 1.4.14, 1.4.15, 1.4.16, 1.4.17, 1.4.18, 1.4.19, 1.4.20, 1.4.21, 1.5.0, 1.5.1, 1.6.0, 1.6.1, 2.0.0, 2.1.0, 2.2.0, 2.3.0