Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05cnZ3LTdteDctaDUzeM4AAlx0

CSRF vulnerability in Jenkins Database Plugin

A cross-site request forgery (CSRF) vulnerability in Jenkins database Plugin 1.6 and earlier allows attackers to connect to an attacker-specified database server using attacker-specified credentials.

Database Plugin 1.7 requires POST requests for the affected form validation method.

Permalink: https://github.com/advisories/GHSA-9rvw-7mx7-h53x
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05cnZ3LTdteDctaDUzeM4AAlx0
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 6 months ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Identifiers: GHSA-9rvw-7mx7-h53x, CVE-2020-2241
References: Repository: https://github.com/jenkinsci/database-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:database
Affected Version Ranges: <= 1.6
Fixed in: 1.7