Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05djN3LW01NTItbTZmZs3tog

Pi Cross-site Scripting vulnerability

A Cross-Site Scripting (XSS) was discovered in pi-engine/pi 2.5.0. The vulnerability exists due to insufficient filtration of user-supplied data (preview) passed to the pi-develop/www/script/editor/markitup/preview/markdown.php URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.

Permalink: https://github.com/advisories/GHSA-9v3w-m552-m6ff
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05djN3LW01NTItbTZmZs3tog
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: about 1 year ago


CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-9v3w-m552-m6ff, CVE-2017-7251
References: Repository: https://github.com/pi-engine/pi
Blast Radius: 7.3

Affected Packages

packagist:pi/pi
Dependent packages: 1
Dependent repositories: 16
Downloads: 20 total
Affected Version Ranges: <= 2.5.0
Fixed in: 2.6.0-alpha1
All affected versions: 2.5.0
All unaffected versions: 2.6.0, 2.6.1, 2.6.2, 2.8.0