Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS05dmdxLXc1cHYtdjc3cc4AA5JF

Liferay Portal stored cross-site scripting (XSS) vulnerability

Stored cross-site scripting (XSS) vulnerability in the Portal Search module's Search Result app in Liferay Portal 7.2.0 through 7.4.3.11, and older unsupported versions, and Liferay DXP 7.4 before update 8, 7.3 before update 4, 7.2 before fix pack 17, and older unsupported versions allows remote authenticated users to inject arbitrary web script or HTML into the Search Result app's search result if highlighting is disabled by adding any searchable content (e.g., blog, message board message, web content article) to the application.

Permalink: https://github.com/advisories/GHSA-9vgq-w5pv-v77q
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS05dmdxLXc1cHYtdjc3cc4AA5JF
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: 23 days ago
Updated: 23 days ago


CVSS Score: 9.6
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Identifiers: GHSA-9vgq-w5pv-v77q, CVE-2024-25145
References:

Affected Packages

maven:com.liferay.portal:release.dxp.bom
Versions: < 7.2.10.fp17, >= 7.3.0, < 7.3.10.u4, >= 7.4.0, < 7.4.3.13u8
Fixed in: 7.2.10.fp17, 7.3.10.u4, 7.4.3.13u8
maven:com.liferay.portal:release.portal.bom
Versions: < 7.4.3.12
Fixed in: 7.4.3.12