Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0yMnE4LWdobXEtNjN2Zs4AA5N4

libgit2-sys affected by memory corruption, denial of service, and arbitrary code execution in libgit2

The libgit2 project fixed three security issues in the 1.7.2 release. These issues are:

The libgit2-sys crate bundles libgit2, or optionally links to a system libgit2 library. In either case, versions of the libgit2 library less than 1.7.2 are vulnerable. The 0.16.2 release of libgit2-sys bundles the fixed version of 1.7.2, and requires a system libgit2 version of at least 1.7.2.

It is recommended that all users upgrade.

Permalink: https://github.com/advisories/GHSA-22q8-ghmq-63vf
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0yMnE4LWdobXEtNjN2Zs4AA5N4
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 9 days ago
Updated: 9 days ago


CVSS Score: 8.6
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Identifiers: GHSA-22q8-ghmq-63vf
References:

Affected Packages

cargo:libgit2-sys
Versions: < 0.16.2
Fixed in: 0.16.2