Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0yMzZoLXIzdzctYzg1Y84AAQ0i

Cross-site Scripting in Apache Atlas

Apache Atlas versions 0.6.0-incubating and 0.7.0-incubating were found vulnerable to Stored Cross-Site Scripting in the edit-tag functionality.

Permalink: https://github.com/advisories/GHSA-236h-r3w7-c85c
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0yMzZoLXIzdzctYzg1Y84AAQ0i
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 8 months ago


CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-236h-r3w7-c85c, CVE-2017-3151
References: Blast Radius: 11.3

Affected Packages

maven:org.apache.atlas:atlas-common
Dependent packages: 17
Dependent repositories: 71
Downloads:
Affected Version Ranges: >= 0.6.0-incubating, < 0.7.1-incubating
Fixed in: 0.7.1-incubating
All affected versions:
All unaffected versions: 0.8.1, 0.8.2, 0.8.3, 0.8.4, 1.0.0, 1.1.0, 1.2.0, 2.0.0, 2.1.0, 2.2.0, 2.3.0