Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0yNTJoLTJjbXEtcG1yNs4AAwXI

easywebpack-cli Path Traversal vulnerability

Directory Traversal vulnerability in easywebpack-cli before 4.5.2 allows attackers to obtain sensitive information via crafted GET request.

Permalink: https://github.com/advisories/GHSA-252h-2cmq-pmr6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0yNTJoLTJjbXEtcG1yNs4AAwXI
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-252h-2cmq-pmr6, CVE-2020-24855
References: Repository: https://github.com/easy-team/easywebpack-cli
Blast Radius: 6.2

Affected Packages

npm:@easy-team/easywebpack-cli
Dependent packages: 33
Dependent repositories: 15
Downloads: 223 last month
Affected Version Ranges: < 4.5.2
Fixed in: 4.5.2
All affected versions: 4.0.0, 4.1.0, 4.1.1, 4.1.2, 4.2.0, 4.2.1, 4.3.0, 4.3.1, 4.3.2, 4.4.0, 4.4.1, 4.4.2, 4.4.3, 4.5.0, 4.5.1
All unaffected versions: 4.5.2