Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0yZjRjLThycDYtZmg2cc4AAl8b

Arbitrary file read vulnerability in Copy data to workspace Jenkins Plugin

Jenkins Copy data to workspace Plugin 1.0 and earlier does not limit which directories can be copied from the Jenkins controller to job workspaces, allowing attackers with Job/Configure permission to read arbitrary files on the Jenkins controller.

Permalink: https://github.com/advisories/GHSA-2f4c-8rp6-fh6q
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0yZjRjLThycDYtZmg2cc4AAl8b
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 6.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Identifiers: GHSA-2f4c-8rp6-fh6q, CVE-2020-2275
References: Blast Radius: 1.0

Affected Packages

maven:org.jvnet.hudson.plugins:copy-data-to-workspace-plugin
Affected Version Ranges: <= 1.0
No known fixed version