Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0yamd3LTI4cWgtNm1nOM4AAyuZ

Jenkins Quay.io trigger Plugin Cross-site Scripting vulnerability

Jenkins Quay.io trigger Plugin 0.1 and earlier does not limit URL schemes for repository homepage URLs submitted via Quay.io trigger webhooks. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to submit crafted Quay.io trigger webhook payloads.

Permalink: https://github.com/advisories/GHSA-2jgw-28qh-6mg8
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0yamd3LTI4cWgtNm1nOM4AAyuZ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: about 1 year ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-2jgw-28qh-6mg8, CVE-2023-30520
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:quayio-trigger
Affected Version Ranges: <= 0.1
No known fixed version