An open API service providing security vulnerability metadata for many open source software ecosystems.
Security Advisories: GSA_kwCzR0hTQS0ybXJxLXc4cHYtNXB2cc4AA5Bn
Malicious input can provoke XSS when preserving comments
There is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the
preserveComments directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output.
Patched in AntiSamy 1.7.5 and later. This is due to parsing behavior in the neko-htmlunit dependency, just by updating to a newer version the issue was solved. See important remediation details in the reference given below.
If you cannot upgrade to a fixed version of the library, the following mitigation can be applied until you can upgrade: Manually edit your AntiSamy policy file (e.g., antisamy.xml) by deleting the
preserveComments directive or setting its value to
false, if present.
As the previously mentioned policy settings are preconditions for the mXSS attack to work, changing them as recommended should be sufficient to protect you against this vulnerability when using a vulnerable version of this library. However, the existing bug would still be present in the parser dependency (neko-htmlunit) and therefore in AntiSamy. The safety of this workaround relies on configurations that may change in the future and don't address the root cause of the vulnerability. As such, it is strongly recommended to upgrade to a fixed version of AntiSamy.
For more information
If you have any questions or comments about this advisory:
Email one of the project co-leaders, listed on the OWASP AntiSamy project page, under "Leaders".Permalink: https://github.com/advisories/GHSA-2mrq-w8pv-5pvq
Source: GitHub Advisory Database
Published: 28 days ago
Updated: 28 days ago
CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Identifiers: GHSA-2mrq-w8pv-5pvq, CVE-2024-23635
Fixed in: 1.7.5