Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0ycnA4LWhmZjktYzV3cs4AA50x

PaddlePaddle Path Traversal vulnerability

Arbitrary File Overwrite Via Path Traversal in paddlepaddle/paddle before 2.6

Permalink: https://github.com/advisories/GHSA-2rp8-hff9-c5wr
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0ycnA4LWhmZjktYzV3cs4AA50x
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 2 months ago
Updated: about 1 month ago


CVSS Score: 9.1
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Identifiers: GHSA-2rp8-hff9-c5wr, CVE-2024-0818
References: Repository: https://github.com/PaddlePaddle/Paddle
Blast Radius: 30.4

Affected Packages

pypi:paddlepaddle
Dependent packages: 41
Dependent repositories: 2,208
Downloads: 253,259 last month
Affected Version Ranges: <= 2.6.0
No known fixed version
All affected versions: 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 2.0.0, 2.0.1, 2.0.2, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.3.2, 2.4.0, 2.4.1, 2.4.2, 2.5.0, 2.5.1, 2.5.2, 2.6.0