Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0yd3h2LTNnNHYtcDc2cM2Hhg

phpSysInfo allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence

Directory traversal vulnerability in index.php in phpSysInfo prior to 3.2.5 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.

Permalink: https://github.com/advisories/GHSA-2wxv-3g4v-p76p
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0yd3h2LTNnNHYtcDc2cM2Hhg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


Identifiers: GHSA-2wxv-3g4v-p76p, CVE-2006-3360
References: Repository: https://github.com/phpsysinfo/phpsysinfo
Blast Radius: 0.0

Affected Packages

packagist:phpsysinfo/phpsysinfo
Dependent packages: 3
Dependent repositories: 9
Downloads: 19,561 total
Affected Version Ranges: < 3.2.5
Fixed in: 3.2.5
All affected versions: 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4
All unaffected versions: 3.2.5, 3.2.6, 3.2.7, 3.2.8, 3.2.9, 3.2.10, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.4.0, 3.4.1, 3.4.2, 3.4.3