Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0ydzhnLW01ajgtN204N80hSQ

Zalgo-like output that crashes the server

Impact

What kind of vulnerability is it? Who is impacted?

colors package caused zalgo-like output (see https://github.com/soketi/soketi/issues/276, https://github.com/Marak/colors.js/issues/289), breaking the servers.

Only NPM users that recently upgraded or installed the NPM package are affected.

Docker users seem to not be affected as the dependencies were bundled at the time of the build, which were tested.

Patches

Has the problem been patched? What versions should users upgrade to?

Latest patch. 0.26.1 to be exact at the time of writing.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

You cannot get around this as it's related to dependencies.

References

Are there any links users can visit to find out more?

For more information

If you have any questions or comments about this advisory:

Permalink: https://github.com/advisories/GHSA-2w8g-m5j8-7m87
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0ydzhnLW01ajgtN204N80hSQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 2 years ago
Updated: over 1 year ago


Identifiers: GHSA-2w8g-m5j8-7m87
References: Repository: https://github.com/soketi/soketi
Blast Radius: 0.0

Affected Packages

npm:@soketi/soketi
Dependent packages: 1
Dependent repositories: 6
Downloads: 3,647 last month
Affected Version Ranges: < 0.26.1
Fixed in: 0.26.1
All affected versions: 0.13.0, 0.13.1, 0.13.2, 0.14.0, 0.14.1, 0.15.0, 0.16.0, 0.17.1, 0.18.0, 0.19.0, 0.19.1, 0.20.0, 0.20.1, 0.21.0, 0.22.0, 0.23.0, 0.23.1, 0.23.2, 0.24.0, 0.24.1, 0.25.0, 0.26.0
All unaffected versions: 0.26.1, 0.26.2, 0.26.3, 0.27.1, 0.28.0, 0.29.0, 0.30.0, 0.30.1, 0.30.2, 0.31.5, 0.32.0, 0.32.1, 0.32.2, 0.33.0, 0.33.1, 0.33.2, 0.33.3, 0.34.0, 0.34.1, 1.0.0, 1.0.1, 1.0.2, 1.1.0, 1.2.0, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.6.1