Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0yeDJxLTJ4cHYtbWNmOc4AAimP

Magento 2 Community Edition SQLi Vulnerability

A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with privileges to an account with Newsletter Template editing permission could exfiltrate the Admin login data, and reset their password, effectively performing a privilege escalation.

As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

Permalink: https://github.com/advisories/GHSA-2x2q-2xpv-mcf9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0yeDJxLTJ4cHYtbWNmOc4AAimP
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: 9 days ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-2x2q-2xpv-mcf9, CVE-2019-8127
References:

Affected Packages

packagist:magento/community-edition
Versions: >= 2.3.0, < 2.3.2-p2, >= 2.2.0, < 2.2.10
Fixed in: 2.3.2-p2, 2.2.10