Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0zMjJ4LWp2NWgtY3ZqaM38Xg

Jenkins Ansible Plugin man in the middle vulnerability

A man in the middle vulnerability exists in Jenkins Ansible Plugin 0.8 and older in AbstractAnsibleInvocation.java, AnsibleAdHocCommandBuilder.java, AnsibleAdHocCommandInvocationTest.java, AnsibleContext.java, AnsibleJobDslExtension.java, AnsiblePlaybookBuilder.java, AnsiblePlaybookStep.java that disables host key verification by default. Ansible Plugin 1.0 now enables host key verification by default, adding options allowing users to opt out.

Permalink: https://github.com/advisories/GHSA-322x-jv5h-cvjh
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0zMjJ4LWp2NWgtY3ZqaM38Xg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 7 months ago


CVSS Score: 5.6
CVSS vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Identifiers: GHSA-322x-jv5h-cvjh, CVE-2018-1000149
References: Repository: https://github.com/jenkinsci/ansible-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:ansible
Affected Version Ranges: <= 0.8
Fixed in: 1.0