Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0zNHEzLXAzNTItYzdxOM4AA5Bm

Central Dogma Authentication Bypass Vulnerability via Session Leakage

Vulnerability Overview

A vulnerability has been identified in Central Dogma versions prior to 0.64.0, allowing for the leakage of user sessions and subsequent authentication bypass. The issue stems from a Cross-Site Scripting (XSS) attack vector that targets the RelayState of Security Assertion Markup Language (SAML).

Impact

Successful exploitation of this vulnerability enables malicious actors to leak user sessions, leading to the compromise of authentication mechanisms. This, in turn, can facilitate unauthorized access to sensitive resources.

Patches

This vulnerability is addressed and resolved in Central Dogma version 0.64.0. Users are strongly encouraged to upgrade to this version or later to mitigate the risk associated with the authentication bypass.

Workarounds

No viable workarounds are currently available for this vulnerability. It is recommended to apply the provided patch promptly.

References

Permalink: https://github.com/advisories/GHSA-34q3-p352-c7q8
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0zNHEzLXAzNTItYzdxOM4AA5Bm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: 28 days ago
Updated: 24 days ago


CVSS Score: 9.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Identifiers: GHSA-34q3-p352-c7q8, CVE-2024-1143
References:

Affected Packages

maven:com.linecorp.centraldogma:centraldogma-server
Versions: < 0.64.1
Fixed in: 0.64.1