Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0zZmhqLXdwdmoteDV3OM4AAwaM

laravel-jqgrid vulnerable to SQL Injection

A vulnerability classified as critical was found in laravel-jqgrid. Affected by this vulnerability is the function getRows of the file src/Mgallegos/LaravelJqgrid/Repositories/EloquentRepositoryAbstract.php. The manipulation leads to sql injection. The name of the patch is fbc2d94f43d0dc772767a5bdb2681133036f935e. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-216271.

Permalink: https://github.com/advisories/GHSA-3fhj-wpvj-x5w8
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0zZmhqLXdwdmoteDV3OM4AAwaM
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 1 year ago
Updated: about 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-3fhj-wpvj-x5w8, CVE-2021-4262
References: Repository: https://github.com/mgallegos/laravel-jqgrid
Blast Radius: 14.0

Affected Packages

packagist:mgallegos/laravel-jqgrid
Dependent packages: 1
Dependent repositories: 27
Downloads: 14,800 total
Affected Version Ranges: <= 1.3.0
No known fixed version
All affected versions: 1.0.0, 1.0.1, 1.0.2, 1.1.0, 1.2.0, 1.2.1, 1.3.0