Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0zaGZxLWN4OWotOTIzd84AA3K0

Attacker can cause Kyverno user to unintentionally consume insecure image

An issue was found in Kyverno that allowed an attacker to control the digest of images used by Kyverno users. The issue would require the attacker to compromise the registry that the Kyverno fetch their images from. The attacker could then return a vulnerable image to the the user and leverage that to further escalate their position. As such, the attacker would need to know which images the Kyverno user consumes and know of one of multiple exploitable vulnerabilities in previous digests of the images. Alternatively, if the attacker has compromised the registry, they could craft a malicious image with a different digest with intentionally placed vulnerabilities and deliver the image to the user.

An attacker was not be able to control other parameters of the image than the digest by exploiting this vulnerability.

Users pulling their images from trusted registries are not impacted by this vulnerability. There is no evidence of this being exploited in the wild.

The issue has been patched in 1.11.0.

The vulnerability was found during an ongoing security audit of Kyverno conducted by Ada Logics, facilitated by OSTIF and funded by the CNCF.

Members of the community have raised concerns over the similarity between this vulnerability and the one identified with CVE-2023-46737; They are two different issues with two different root causes and different levels of impact. Some differences are:

Permalink: https://github.com/advisories/GHSA-3hfq-cx9j-923w
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0zaGZxLWN4OWotOTIzd84AA3K0
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 14 days ago
Updated: 14 days ago


CVSS Score: 7.1
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-3hfq-cx9j-923w, CVE-2023-47630
References:

Affected Packages

go:github.com/kyverno/kyverno
Versions: < 1.10.5
Fixed in: 1.10.5