Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS0zcmZyLW1wZmotMmp3cc4AA5JP

Pimcore Admin Classic Bundle permissions are not getting checked when working with tags

Impact

You can create, delete etc. tags without having the permission to do so.
This vulnerability allows an attacker to perform broken access control and add tags to admin panel and add dumy data. One can do this as intruder and add text parameters with random numbers and this will effect integrity and availability.

Patches

Available in version 1.3.3.

Workarounds

Apply this pull request manually: https://github.com/pimcore/admin-ui-classic-bundle/pull/412

References

Permalink: https://github.com/advisories/GHSA-3rfr-mpfj-2jwq
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS0zcmZyLW1wZmotMmp3cc4AA5JP
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 23 days ago
Updated: 23 days ago


CVSS Score: 6.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Identifiers: GHSA-3rfr-mpfj-2jwq, CVE-2024-24822
References:

Affected Packages

packagist:pimcore/admin-ui-classic-bundle
Versions: < 1.3.3
Fixed in: 1.3.3