Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Advisories: GSA_kwCzR0hTQS12M2NnLTdyOWgtcjJnNs4AAxIz

Field-level security issue with .keyword fields in OpenSearch

Advisory title: Field-level security issue with .keyword fields

Affected versions:

OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1

Patched versions:

OpenSearch 1.3.8 and 2.5.0

Impact:

There is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields.

This issue is only present for authenticated users with read access to the indexes containing the restricted fields.

Workaround:

FLS rules that use explicit exclusions can be written to grant explicit access instead. Policies authored in this way are not subject to this issue.

Patches:

OpenSearch versions 1.3.8 and 2.5.0 contain a fix for this issue.

For more information:

If you have any questions or comments about this advisory, please contact AWS/Amazon Security via our issue reporting page (https://aws.amazon.com/security/vulnerability-reporting/) or directly via email to [email protected]. Please do not create a public GitHub issue.

Permalink: https://github.com/advisories/GHSA-v3cg-7r9h-r2g6

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 14 days ago
Updated: 12 days ago

CVSS Score: 5.7
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N

Identifiers: GHSA-v3cg-7r9h-r2g6, CVE-2023-23613
References:

Affected Packages

maven:org.opensearch:opensearch
Versions: >= 2.0.0, < 2.5.0, < 1.3.8
Fixed in: 2.5.0, 1.3.8