Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12NDl4LThodm0tcTM0N84AAUGo

Exposure of Sensitive Information in Apache Pluto

The PortletV3AnnotatedDemo Multipart Portlet war file code provided in Apache Pluto version 3.0.0 could allow a remote attacker to obtain sensitive information, caused by the failure to restrict path information provided during a file upload. An attacker could exploit this vulnerability to obtain configuration data and other sensitive information.

Permalink: https://github.com/advisories/GHSA-v49x-8hvm-q347
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12NDl4LThodm0tcTM0N84AAUGo
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Identifiers: GHSA-v49x-8hvm-q347, CVE-2018-1306
References: Blast Radius: 11.1

Affected Packages

maven:org.apache.portals.pluto:pluto-container
Dependent packages: 24
Dependent repositories: 30
Downloads:
Affected Version Ranges: = 3.0.0
Fixed in: 3.0.1
All affected versions: 3.0.0
All unaffected versions: 2.0.0, 2.0.1, 2.0.2, 2.0.3, 3.0.1, 3.1.0, 3.1.1, 3.1.2