An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12NnJ3LWhoZ2ctd2M0eM4AA7I5

Evmos vulnerable to DOS and transaction fee expropiation through Authz exploit


What kind of vulnerability is it? Who is impacted?

An attacker can use this bug to bypass the block gas limit and gas payment completely to perform a full Denial-of-Service against the chain.


Evmos versions below v11.0.1 do not check for MsgEthereumTx messages that are nested under other messages. This allows a malicious actor to perform EVM transactions that do not meet the checks performed under newEthAnteHandler. This opens the possibility for the DOS of validators and consequently halt the chain through an infinite EVM execution.

Additional details

The attack scenario is as follows:

  1. The attacker deploys a simple smart contract with an infinite loop to the chain.
  2. The attacker calls the smart contract using an embedded transaction with an extremely high gas value (uint64 max or similar).
  3. Once the transaction is included in a block, nodes will try to execute the EVM transaction with almost infinite gas and get stuck. This stops new block creation and effectively halts the chain, requiring a manual restart of all nodes.

Users Impacted

All Evmos users are impacted by this vulnerability as it has the potential to halt the chain. Users' funds and chain state are safe but when under attack, the chain could be deemed unusable.


Has the problem been patched? What versions should users upgrade to?

The vulnerability has been patched on Evmos versions ≥v12.0.0.


As a temporary workaround, the fix blocks MsgEthereumTxs messages from being sent under the authz module's MsgExec message. It also covers the scenario in which MsgEthereumTx are deeply nested by:

This is done by adding an additional AnteHandler decorator (AuthzLimiterDecorator) for Cosmos and EIP-712 transactions.

This is a state machine-breaking change as it restricts previously allowed messages and thus requires a hard-fork upgrade.


Are there any links users can visit to find out more?

For more information

If you have any questions or comments about this advisory:

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 1 month ago
Updated: about 1 month ago

CVSS Score: 9.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Identifiers: GHSA-v6rw-hhgg-wc4x
References: Repository:
Blast Radius: 1.0

Affected Packages
Dependent packages: 9
Dependent repositories: 0
Affected Version Ranges: < 12.0.0
Fixed in: 12.0.0
All affected versions: 11.0.0, 11.0.1, 11.0.2
All unaffected versions: