Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12ODRnLWNmNWoteGpxeM0poQ

Path Traversal in Apache James Server

Apache James Server prior to version 3.6.2 contains a path traversal vulnerability. The fix for CVE-2021-40525 does not prepend delimiters upon valid directory validations. Affected implementations include: - maildir mailbox store - Sieve file repository This enables a user to access other users data stores (limited to user names being prefixed by the value of the username being used).

Permalink: https://github.com/advisories/GHSA-v84g-cf5j-xjqx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12ODRnLWNmNWoteGpxeM0poQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: about 1 year ago


Identifiers: GHSA-v84g-cf5j-xjqx, CVE-2022-22931
References: Repository: https://github.com/apache/james-project
Blast Radius: 0.0

Affected Packages

maven:org.apache.james:james-server
Dependent packages: 1
Dependent repositories: 15
Downloads:
Affected Version Ranges: < 3.6.2
Fixed in: 3.6.2
All affected versions: 3.0.0, 3.0.1, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.5.0, 3.6.0
All unaffected versions: 3.6.2, 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.7.5, 3.8.0, 3.8.1