Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12OGdyLW01MzMtZ2hqOc4AA1_w

Vulnerable OpenSSL included in cryptography wheels

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 2.5-41.0.3 are vulnerable to several security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20230908.txt.

If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

Permalink: https://github.com/advisories/GHSA-v8gr-m533-ghj9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12OGdyLW01MzMtZ2hqOc4AA1_w
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: 10 months ago
Updated: 10 months ago


Identifiers: GHSA-v8gr-m533-ghj9
References: Repository: https://github.com/pyca/cryptography
Blast Radius: 0.0

Affected Packages

pypi:cryptography
Dependent packages: 3,396
Dependent repositories: 131,580
Downloads: 239,000,563 last month
Affected Version Ranges: >= 2.5, < 41.0.4
Fixed in: 41.0.4
All affected versions: 2.6.1, 2.9.1, 2.9.2, 3.1.1, 3.2.1, 3.3.1, 3.3.2, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.6, 3.4.7, 3.4.8, 35.0.0, 36.0.0, 36.0.1, 36.0.2, 37.0.0, 37.0.1, 37.0.2, 37.0.3, 37.0.4, 38.0.0, 38.0.1, 38.0.2, 38.0.3, 38.0.4, 39.0.0, 39.0.1, 39.0.2, 40.0.0, 40.0.1, 40.0.2, 41.0.0, 41.0.1, 41.0.2, 41.0.3
All unaffected versions: 0.2.1, 0.2.2, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.6.1, 0.7.1, 0.7.2, 0.8.1, 0.8.2, 0.9.1, 0.9.2, 0.9.3, 1.0.1, 1.0.2, 1.1.1, 1.1.2, 1.2.1, 1.2.2, 1.2.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.5.1, 1.5.2, 1.5.3, 1.7.1, 1.7.2, 1.8.1, 1.8.2, 2.0.1, 2.0.2, 2.0.3, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.2.1, 2.2.2, 2.3.1, 2.4.1, 2.4.2, 41.0.4, 41.0.5, 41.0.6, 41.0.7, 42.0.0, 42.0.1, 42.0.2, 42.0.3, 42.0.4, 42.0.5, 42.0.6, 42.0.7, 42.0.8