Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12Yzl4LWdtbXItcDdqas4AAwP1

Duplicate advisory: @claviska/jquery-minicolors vulnerable to Cross-site Scripting

Duplicate advisory

This advisory has been withdrawn because it is a duplicate of GHSA-crh5-vv2v-c82q. This link is maintained to preserve external references.

Original Description

A vulnerability was found in claviska jquery-minicolors up to 2.3.5. It has been rated as problematic. Affected by this issue is some unknown functionality of the file jquery.minicolors.js. The manipulation leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.3.6 is able to address this issue. The name of the patch is ef134824a7f4110ada53ea6c173111a4fa2f48f3. It is recommended to upgrade the affected component. VDB-215306 is the identifier assigned to this vulnerability.

Permalink: https://github.com/advisories/GHSA-vc9x-gmmr-p7jj
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12Yzl4LWdtbXItcDdqas4AAwP1
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: about 1 year ago

Widthdrawn: about 1 year ago

CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-vc9x-gmmr-p7jj, CVE-2021-4243
References: Repository: https://github.com/claviska/jquery-minicolors
Blast Radius: 16.6

Affected Packages

npm:@claviska/jquery-minicolors
Dependent packages: 42
Dependent repositories: 529
Downloads: 64,653 last month
Affected Version Ranges: < 2.3.6
Fixed in: 2.3.6
All affected versions: 2.2.4, 2.2.5, 2.2.6, 2.3.2, 2.3.3, 2.3.4, 2.3.5
All unaffected versions: 2.3.6