Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12ZjhoLTJ3d2otanEyMs4AAxpX

Privilege escalation in Apache ShenYu

Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu. ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own. This issue affects Apache ShenYu: 2.5.0. Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958 https://github.com/apache/shenyu/pull/3958.

Permalink: https://github.com/advisories/GHSA-vf8h-2wwj-jq22
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12ZjhoLTJ3d2otanEyMs4AAxpX
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 4 months ago
Updated: 3 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-vf8h-2wwj-jq22, CVE-2022-42735
References:

Affected Packages

maven:org.apache.shenyu:shenyu-admin
Versions: < 2.5.1
Fixed in: 2.5.1