Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12ajNqLThtNngtbWpxNs0sMg

Missing permission check in Jenkins SCP publisher Plugin

SCP publisher Plugin 1.8 and earlier does not perform a permission check in a method implementing form validation.

This allows attackers with Overall/Read permission to connect to an attacker-specified SSH server using attacker-specified credentials.

Additionally, this form validation method does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability.

Permalink: https://github.com/advisories/GHSA-vj3j-8m6x-mjq6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12ajNqLThtNngtbWpxNs0sMg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: 7 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-vj3j-8m6x-mjq6, CVE-2022-25199
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:scp
Affected Version Ranges: <= 1.8
No known fixed version