Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12ajk1LTJmOXEteDdoNs4AAhFI

glot-code-runner RCE

The default configuration of glot-www through 2018-05-19 allows remote attackers to execute arbitrary code because glot-code-runner supports os.system within a "python" "files" "content" JSON file.

Permalink: https://github.com/advisories/GHSA-vj95-2f9q-x7h6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12ajk1LTJmOXEteDdoNs4AAhFI
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 2 years ago
Updated: about 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-vj95-2f9q-x7h6, CVE-2018-15747
References: Repository: https://github.com/prasmussen/glot-code-runner
Blast Radius: 1.0

Affected Packages

go:github.com/prasmussen/glot-code-runner
Dependent packages: 0
Dependent repositories: 0
Downloads:
Affected Version Ranges: <= 2018-05-19
No known fixed version
All affected versions: