Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12bXZwLTJoaHgtcmdtOM4AAi-c

Cross-Site Request Forgery in Jenkins Gerrit Trigger Plugin

A cross-site request forgery vulnerability in Jenkins Gerrit Trigger Plugin 2.30.1 and earlier allows attackers to connect to an attacker-specified HTTP URL or SSH server using attacker-specified credentials.

Permalink: https://github.com/advisories/GHSA-vmvp-2hhx-rgm8
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12bXZwLTJoaHgtcmdtOM4AAi-c
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: 7 months ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-vmvp-2hhx-rgm8, CVE-2019-16551
References: Repository: https://github.com/jenkinsci/gerrit-trigger-plugin
Blast Radius: 11.0

Affected Packages

maven:com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
Dependent packages: 0
Dependent repositories: 18
Downloads:
Affected Version Ranges: < 2.30.2
Fixed in: 2.30.2
All affected versions: 2.1.0, 2.2.0
All unaffected versions: