Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS12cGdmLWZnbTgtZ3hyMs4AAvkR

Apache DolphinScheduler vulnerable to Path Traversal

Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.

Permalink: https://github.com/advisories/GHSA-vpgf-fgm8-gxr2
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS12cGdmLWZnbTgtZ3hyMs4AAvkR
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 6.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Identifiers: GHSA-vpgf-fgm8-gxr2, CVE-2022-26884
References: Repository: https://github.com/apache/dolphinscheduler
Blast Radius: 1.0

Affected Packages

maven:org.apache.dolphinscheduler:dolphinscheduler
Dependent packages: 0
Dependent repositories: 0
Downloads:
Affected Version Ranges: < 2.0.6
Fixed in: 2.0.6
All affected versions: 1.2.0, 1.2.1, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5
All unaffected versions: 2.0.6, 2.0.7, 2.0.8, 2.0.9, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.2.0, 3.2.1