Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13N3I2LXY0ajctaDk0d84AAygm

Apache James server's JMX management service vulnerable to privilege escalation by local user

Apache James server version 3.7.3 and earlier provides a JMX management service without authentication by default. This allows privilege escalation by a malicious local user. Administrators are advised to disable JMX, or set up a JMX password. Note that version 3.7.4 onward will set up a JMX password automatically for Guice users.

Permalink: https://github.com/advisories/GHSA-w7r6-v4j7-h94w
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13N3I2LXY0ajctaDk0d84AAygm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 7.8
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-w7r6-v4j7-h94w, CVE-2023-26269
References: Blast Radius: 8.9

Affected Packages

maven:org.apache.james:javax-mail-extension
Dependent packages: 27
Dependent repositories: 14
Downloads:
Affected Version Ranges: < 3.7.4
Fixed in: 3.7.4
All affected versions: 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.5.0, 3.6.0, 3.6.2, 3.7.0, 3.7.1, 3.7.2, 3.7.3
All unaffected versions: 3.7.4, 3.7.5, 3.8.0, 3.8.1