Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13NTh2LXIzY3AtcXI5M84AA9bt

@amoy/common v was discovered to contain a prototype pollution via the function extend

amoyjs amoy common v1.0.10 was discovered to contain a prototype pollution via the function extend. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.

Permalink: https://github.com/advisories/GHSA-w58v-r3cp-qr93
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13NTh2LXIzY3AtcXI5M84AA9bt
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 16 days ago
Updated: 12 days ago


CVSS Score: 7.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Identifiers: GHSA-w58v-r3cp-qr93, CVE-2024-38994
References: Blast Radius: 4.4

Affected Packages

npm:@amoy/common
Dependent packages: 6
Dependent repositories: 4
Downloads: 93 last month
Affected Version Ranges: = 1.0.10
No known fixed version
All affected versions: 1.0.10