Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13Njk1LXAzajUtaHJqOc4AAxzH

Apache Airflow AWS Provider Generates Error Message Containing Sensitive Information

Generation of Error Message Containing Sensitive Information vulnerability in the Apache Airflow AWS Provider. This issue affects Apache Airflow AWS Provider versions before 7.2.1.

Permalink: https://github.com/advisories/GHSA-w695-p3j5-hrj9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13Njk1LXAzajUtaHJqOc4AAxzH
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Identifiers: GHSA-w695-p3j5-hrj9, CVE-2023-25956
References: Repository: https://github.com/apache/airflow
Blast Radius: 17.0

Affected Packages

pypi:apache-airflow-providers-amazon
Dependent packages: 27
Dependent repositories: 184
Downloads: 4,325,586 last month
Affected Version Ranges: < 7.2.1
Fixed in: 7.2.1
All affected versions: 1.0.0, 1.1.0, 1.2.0, 1.3.0, 1.4.0, 2.0.0, 2.1.0, 2.2.0, 2.3.0, 2.4.0, 2.5.0, 2.6.0, 3.0.0, 3.1.1, 3.2.0, 3.3.0, 3.4.0, 4.0.0, 4.1.0, 5.0.0, 5.1.0, 6.0.0, 6.1.0, 6.2.0, 7.0.0, 7.1.0, 7.2.0
All unaffected versions: 7.2.1, 7.3.0, 7.4.0, 7.4.1, 8.0.0, 8.1.0, 8.2.0, 8.3.0, 8.3.1, 8.4.0, 8.5.0, 8.5.1, 8.6.0, 8.7.0, 8.7.1, 8.8.0, 8.9.0, 8.10.0, 8.11.0, 8.12.0, 8.13.0, 8.14.0, 8.15.0, 8.16.0, 8.17.0, 8.18.0, 8.19.0, 8.20.0, 8.21.0, 8.22.0, 8.23.0, 8.24.0, 8.25.0, 8.26.0