Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13ZzJmLTlyZjctNDhnbc4AAv6P

Missing permission check in Jenkins loader.io Plugin allows enumerating credentials IDs

loader.io Plugin 1.0.1 and earlier does not perform a permission check in an HTTP endpoint.

This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability.

As of publication of this advisory, there is no fix.

Permalink: https://github.com/advisories/GHSA-wg2f-9rf7-48gm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13ZzJmLTlyZjctNDhnbc4AAv6P
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 4.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-wg2f-9rf7-48gm, CVE-2022-45390
References: Blast Radius: 1.0

Affected Packages

maven:io.loader:loaderio-jenkins-plugin
Affected Version Ranges: <= 1.0.1
No known fixed version