An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13cHFyLWpjcHgtNzQ1cs4AAtG2

Incorrect handling of invalid surrogate pair characters


What kind of vulnerability is it? Who is impacted?

Anyone parsing JSON from an untrusted source is vulnerable.

JSON strings that contain escaped surrogate characters not part of a proper surrogate pair were decoded incorrectly. Besides corrupting strings, this allowed for potential key confusion and value overwriting in dictionaries.


# An unpaired high surrogate character is ignored.
>>> ujson.loads(r'"\uD800"')
>>> ujson.loads(r'"\uD800hello"')

# An unpaired low surrogate character is preserved.
>>> ujson.loads(r'"\uDC00"')

# A pair of surrogates with additional non surrogate characters pair up in spite of being invalid.
>>> ujson.loads(r'"\uD800foo bar\uDC00"')
'foo bar𐀀'


Has the problem been patched? What versions should users upgrade to?

Users should upgrade to UltraJSON 5.4.0.

From version 5.4.0, UltraJSON decodes lone surrogates in the same way as the standard library's json module does, preserving them in the parsed output:

>>> ujson.loads(r'"\uD800"')
>>> ujson.loads(r'"\uD800hello"')
>>> ujson.loads(r'"\uDC00"')
>>> ujson.loads(r'"\uD800foo bar\uDC00"')
'\ud800foo bar\udc00'


Is there a way for users to fix or remediate the vulnerability without upgrading?

Short of switching to an entirely different JSON library, there are no safe alternatives to upgrading.

For more information

If you have any questions or comments about this advisory:

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago

CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-wpqr-jcpx-745r, CVE-2022-31116
References: Repository:
Blast Radius: 31.9

Affected Packages

Dependent packages: 520
Dependent repositories: 18,137
Downloads: 11,288,487 last month
Affected Version Ranges: < 5.4.0
Fixed in: 5.4.0
All affected versions: 2.0.0, 2.0.1, 2.0.2, 2.0.3, 3.0.0, 3.1.0, 3.2.0, 4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.2.0, 4.3.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0
All unaffected versions: 5.4.0, 5.5.0, 5.6.0, 5.7.0, 5.8.0, 5.9.0