Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13cnA2LTl3N2YtM3d4Z80kAA

calibre-web is vulnerable to Cross-site Scripting

calibre-web is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Permalink: https://github.com/advisories/GHSA-wrp6-9w7f-3wxg
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13cnA2LTl3N2YtM3d4Z80kAA
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: about 1 year ago


CVSS Score: 7.3
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Identifiers: GHSA-wrp6-9w7f-3wxg, CVE-2021-4170
References: Repository: https://github.com/janeczku/calibre-web
Blast Radius: 0.0

Affected Packages

pypi:calibreweb
Dependent packages: 0
Dependent repositories: 1
Downloads: 1,425 last month
Affected Version Ranges: < 0.6.15
Fixed in: 0.6.15
All affected versions: 0.6.12, 0.6.13, 0.6.14
All unaffected versions: 0.6.15, 0.6.16, 0.6.17, 0.6.18, 0.6.19, 0.6.20, 0.6.21