Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13cnFjLXE4cDUtNzZtNc4AASj3

Incorrect Authorization in Jenkins Gerrit Trigger Plugin

An improper authorization vulnerability exists in Jenkins Gerrit Trigger Plugin 2.27.4 and earlier in GerritManagement.java, GerritServer.java, and PluginImpl.java that allows an attacker with Overall/Read access to retrieve some configuration information about Gerrit in Jenkins.

Permalink: https://github.com/advisories/GHSA-wrqc-q8p5-76m5
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13cnFjLXE4cDUtNzZtNc4AASj3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 7 months ago


CVSS Score: 4.3
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-wrqc-q8p5-76m5, CVE-2018-1000105
References: Repository: https://github.com/jenkinsci/gerrit-trigger-plugin
Blast Radius: 5.4

Affected Packages

maven:com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger
Dependent packages: 0
Dependent repositories: 18
Downloads:
Affected Version Ranges: < 2.27.5
Fixed in: 2.27.5
All affected versions: 2.1.0, 2.2.0
All unaffected versions: