Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS13djI4LTdmcHctZmo0Oc4AA6Vg

Lektor does not sanitize database path traversal

Lektor before 3.3.11 does not sanitize DB path traversal. Thus, shell commands might be executed via a file that is added to the templates directory, if the victim's web browser accesses an untrusted website that uses JavaScript to send requests to localhost port 5000, and the web browser is running on the same machine as the "lektor server" command.

Permalink: https://github.com/advisories/GHSA-wv28-7fpw-fj49
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS13djI4LTdmcHctZmo0Oc4AA6Vg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 months ago
Updated: about 1 month ago


Identifiers: GHSA-wv28-7fpw-fj49, CVE-2024-28335
References: Repository: https://github.com/lektor/lektor
Blast Radius: 0.0

Affected Packages

pypi:Lektor
Dependent packages: 6
Dependent repositories: 95
Downloads: 3,793 last month
Affected Version Ranges: >= 3.4.0b1, < 3.4.0b11, >= 0, < 3.3.11
Fixed in: 3.4.0b11, 3.3.11
All affected versions: 1.2.1, 3.0.1, 3.1.1, 3.1.2, 3.1.3, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.5, 3.3.6, 3.3.7, 3.3.8, 3.3.9, 3.3.10, 3.4.0-b1, 3.4.0-b10
All unaffected versions: 3.3.11